Watchguard Releases 11.8.3 Update 1 to fix Heartbleed

As the world scrambles to correct an open SSL vulnerability called Heartbleed, our customers with Watchguard Firewalls that are current on their Live Security subscriptions will be able to upgrade the IOS to 11.8.3u1 thereby addressing the potential vulnerability.  Watchguard has not been made aware of ANY breaches, but because of its critical nature, we along with Watchguard suggest all customers apply this essential patch. Our support staff is available to assist in performing this update.  This release applies to all XTM appliances except XTM 21/21-w, 22/22-w, or 23/23-w but only to those already running version 11.8.x of the firmware.

Speak Your Mind

*